Jupyter server immediately crashing inside pycharm

Completed

I get the following error when I try to launch jupyter from inside pycharm. I have verified that libffi.so.7 exists and running jupyter outside of pycharm works correctly.

An additional note: pycharm can't install jupyter either, it ends up giving the same error for libffi.so.7 but installing from the command line works fine.

system Info: Pop_OS 20.04

Pycharm - latest flatplak

4 comments
Comment actions Permalink

How did you create this environment?

Is it reproducible with a new virtualenv created from PyCharm?

0
Comment actions Permalink

Python 3.8.3 installed using pyenv, the env was created using virtualenv. It is reproducible in a virtualenv created by pycharm.

Could it be something to do with flatpak? because I was running the same config on ubuntu 20.04 with the snap version of pycharm without any problem

0
Comment actions Permalink

Yes, I guess it can be related to flatpak since it's not an official distribution channel, but it's still weird. Any chance you could reinstall it with snap or manually using tar archive?

0
Comment actions Permalink

I tried it with the tar archive and its working. I guess its a problem with the flatpak.

0

Please sign in to leave a comment.