DataGrip Export Data

Answered

现在,当我使用导出功能时,我感觉不太好。

此图片为plsql导出数据,它将insertsql语句分为1和2,关键字为小写

Now, when I use the export function, I feel not very good.

This picture is the plsql export data, it divides the
insertsql statement into 1 and 2, the keyword is lowercase

但是datagrip只有一行,并且关键字是大写,这将非常不友好,当有很多数据字段时,它将非常长。

But the datagrid has only one row, and the keyword is 
capitalized, which will be very unfriendly.
When there are many data fields, it will be very long.

 

5 comments
Comment actions Permalink

@兵长,

You can change that behavior by setting SQL format settings (Preferences -> Editor -> Code Style -> SQL -> PostgreSQL / Case & Queries tabs) and then invoking reformat code action:

 

Additionally, upvote an issue https://youtrack.jetbrains.com/issue/DBE-5376

 

0
Comment actions Permalink

I have reformatted the exported statement according to your settings,but there is no space between each statement。

How to make more space in the middle of each line when I copy the query results and copy to edit panel?Like the second picture

0
Comment actions Permalink

There is no option to put a new line after `;`.
Follow and up vote an issue https://youtrack.jetbrains.com/issue/DBE-3999.

1
Comment actions Permalink

thank you,I hope datagrip will have this function later。

In the process of using, another function is not very convenie。

like plsql,when the field is very long, it can be displayed in a new line,

but datagrip  without the function of this branch, when the field is very long, it will be difficult to see all the contents of the field

0
Comment actions Permalink

For this IDE has `Edit maximized` and `View maximized`(available in 2020.2 EAP) features.

Read Cells sections in our help

0

Please sign in to leave a comment.