PyCharm remote-debugger is connected but stuck

Hi,

I'm using PyCharm's python-debug-server feature in order to debug python code from remote.

I've inserted the needed lines to the code in order to connect to the debug server ('pydevd_pycharm.settrace' etc..).

The remote interpreter succeeded with connecting to the debug server, but then all I see in the debug console is:

Waiting for process connection...
Connected to pydev debugger (build 201.7223.92)

After the connection setup, the debugger is stuck and I cant press on the 'resume program' button, no frames are available, no variables state, step into/over buttons are on disable mode (grayed and can't be pressed), and basically - the debugger is not working...

 

Please help :)

Thanks

3 comments
Comment actions Permalink

Hello, 

 

Please attach a screenshot of the Remote Debug Server Configuration https://www.jetbrains.com/help/pycharm/remote-debugging-with-product.html#remote-debug-config , the Debug Console view when the debug started and , "no frames are available, no variables state, step into/over buttons are on disable mode (grayed and can't be pressed)" 

Does it happen with any code or a specific one? 

0
Comment actions Permalink

Hi,

 

First, thanks for the reply.

Here are the remote-debug config screenshots:

  - Main config

  - Mapping config

 

When I'm starting the debugger, that's how my IDE looks like:

You can see at the console that the debug server is waiting for a connection, and in addition, you can see that I've inserted a set_trace line on line number 350.

When I trigger the app into the code section that connecting the debug server, you can see in the next screenshot that there is a connection, but at that point I'm expecting for the debugger to tell me something about the invalid file path mapping, but here nothing happens, and its just stuck (usually without path mapping configuration like our scenario, I see a new gray tab which offers me three options: 1. download the code file from the remote side, 2. try to find auto path mapping, 3. open path mapping configuration window. In our case that's not happening).

 

Here you can see that the debugger is connected:

And when I'm moving to the debugger tab (left to the debugger console), you can see that the buttons are grayed and disabled, the the 'Frame are not available' message

 

Its happens when I'm running a code that deployed inside a remote docker container. When I'm deploying the code on a remote host, everything works fine, but  the issues come when trying to debug code which deployed into a docker container on a remote host.

The needed ports are open (you can see that the debugger Is connected) so I don't think its a network issue.

 

Please help :)

Thanks

 

0
Comment actions Permalink

You don't seem to have any breakpoints set and pydevd_pycharm.settrace() function has suspend argument set to False.
Have you tried setting it to True?

0

Please sign in to leave a comment.