Cannot change integrated security setting in database tool

I am using PyCharm 2020.2 Pro.  Trying to connect to an  SQL Server database with User/Password authentication in the Database tool.  I cannot change the advanced integratedSecurity setting to false.  It always reverts to true.  I am easily able to connect when I use DataGrip.  Please advise.

10 comments
Comment actions Permalink

Hi, could you please collect and upload Logs from **Help | Collect Logs and Diagnostic Data** after reproducing the issue? 

You can use our uploading service at https://uploads.jetbrains.com/ , and provide upload ID in your reply.

0
Comment actions Permalink

Hello.  The upload ID is  2020_08_28_Mv7aBRBjDYX1nncf .  Again I have the same settings in DataGrip and have no issue connecting.

0
Comment actions Permalink

I see you are using MSSQL driver v.7.0, could you please switch to 8.2.2 and try again?

0
Comment actions Permalink

sorry but that didn't fix the issue.  still cannot change the integratedSecurity field in the Advanced section.  it's remains stuck at true and I get "Windows logins are not supported in this version of SQL Server" as a result.  Datagrip connects without any issue (no problem w/ the integratedSecurity field).  I can even connect using a python script w/ pyodbc.  no issues using microsoft's SSMS either

0
Comment actions Permalink

please try to delete data source, restart PyCharm, go to DataGrip -> right-click on needed data source -> database tools -> copy datasource to clipboard, go back to PyCharm, in Database tool window click Add(+) -> Data Source from clipboard -> select this data source and click 'Refresh' button on top, it will ask for password and should connect then.

0
Comment actions Permalink

That did not work either.  IntegratedSecurity field still stuck on true.  If I switch to an Azure SQL, then the encrypt field is stuck on true and won't change.

 

0
Comment actions Permalink

any fix to this?

0
Comment actions Permalink

please try to add to the very end of connection URL

;integratedSecurity=false;

and try again. it should override setting on advanced tab.

0
Comment actions Permalink

unfortunately that did not fix it either

0
Comment actions Permalink

Ajacobs1214,

Looks like an issue. Try the following. 



  1. On data source `General`tab set user/password for `Authentication`
  2. Click `Apply`

  3. Go to `Advanced` tab and change `integratedSecurity` to `false`
  4. Click `Apply`
  5. Click `Ok`



If it didn’t help, I’d create a new data source as a workaround and would file an issue.

0

Please sign in to leave a comment.