The project doesn't open in a new window

The problem with pycharm. The project doesn't open in a new window, always opens a tab in the current window, how can I fix this?

18 comments
Comment actions Permalink

Have you checked Preferences | Appearance & Behavior | System Settings | Project | Open project in setting? Perhaps it's set to Current window.

If not, could you share a screenshot showing what it looks like when you open a second project?

2
Comment actions Permalink

Encountered same issue on MacOS BigSur

When I try to open new project it's just append to the same window, see screen below

Here goes my IDE Settings

 

0
Comment actions Permalink

Hello Artyomshorin95 , 

 

Please upload your logs folder zipped from ***Help | Collect logs and Diagnostic Data***   and a screencast presenting the behaviour  to the FTP

https://uploads.jetbrains.com/ and please let me know the filename. 

0
Comment actions Permalink

Hello, I have the same issue. Is there any update? Thanks.

0
Comment actions Permalink

Hello Jakub Begera

 

Could you please provide information requested above? Thank you!

0
Comment actions Permalink

Hello, 

 

Please take a look at this ticket https://youtrack.jetbrains.com/issue/JBR-2879 it should be fixed in 2020.3 or 2020.2.4. 

I apologise for the inconvenience. 

0
Comment actions Permalink

2021.1 same issue...

Was it fixed really?

0
Comment actions Permalink

I've encountered this error for some time now, it still persist in 2021.1.1.

0
Comment actions Permalink

Tomas Sjosten Hi bro, I have fixed this issuse.  file> Manage IDE Setting> Resotre Default Setting

restart the IDE then import your custom setting...

I fixed two issuses by this, one is open tab, another is commit message is missing...

sorry for my poor English hop you can understan what I said...

0
Comment actions Permalink

啤酒饮料矿泉水 Hi!

Thanks for the help!
I tried but the problem still persist for me. Even when restored the outcome is the same and the setting is to open in new window:

0
Comment actions Permalink

@Tomas Sjosten

What option do you have selected here?

4
Comment actions Permalink

Tomas Sjosten  😂    My IDE is not working again...  I don't know why... 

Sergey Karpov Hi bro, My setting is same to your

0
Comment actions Permalink

啤酒饮料矿泉水  :D I'm sorry to hear that! It's a minor issue but I change projects quite frequently, it's getting anoying.

Sergey Karpov thanks alot for taking time! I have the same setting as you there though, so no progress in the issue I'm afraid :/.

 

0
Comment actions Permalink

Tomas Sjosten

Could you share a screenshot showing what the issue in PyCharm looks like in your case?

0
Comment actions Permalink

you have to go to your Mac System Preferences/General/Prefer Tabs: "Never" when opening documents
that is what fixed it for me switching from "in full screen" to "Never" and now new projects are opened in a completely separate window instead of a stupid tab.

6
Comment actions Permalink

Perfect, works like a charm Idebie - thanks alot!

2
Comment actions Permalink

Sergey Karpov You saved my day!

0

Please sign in to leave a comment.