Error in installing numpy on python 3.9

Answered

Hi,

I am getting the attached error while installing numpy on python interpreter 3.9. Please note that i could install numpy on interpreter 3.8 without any issues and it still runs fine.

The error says 'install Python development packages'. However, I am not able to get any python-dev package in PyCharm for pip install.

2 comments
Comment actions Permalink

Hello,

The issue is not related to PyCharm because the installation is performed by pip.

Try installing  python-dev as mentioned in https://stackoverflow.com/questions/24892810/python-3-4-and-2-7-cannot-install-numpy-package-for-python-3-4

For your Python version, run

apt-get install python3.9-dev
1
Comment actions Permalink

Thank you Sergey. It worked like a charm :)

0

Please sign in to leave a comment.