unsupported Java Version

Answered

Just downloaded an update with new version, and now I am unable to open IJ, seeing this message in a popup window.

Cannot start under Java 1.8.0_202-release-b1491: Java 11 or later is required.

reinstalled Java 11 and still seeing the same error

11 comments
Comment actions Permalink

Please see https://intellij-support.jetbrains.com/hc/en-us/articles/206544879. It looks like you override the default JetBrains Runtime either via the environment variable or via idea.jdk file in the config directory (https://www.jetbrains.com/help/idea/tuning-the-ide.html#config-directory).

-1
Comment actions Permalink

my current Intellij version

0
Comment actions Permalink

For IntelliJ IDEA CE the config directory would be /Users/<user>/Library/Application Support/JetBrains/IdeaIC2020.3

If you have idea.jdk file there, delete it.

6
Comment actions Permalink

Thanks Serge! After delete the idea.jdk file, it works now.

 

1
Comment actions Permalink

I'm on a PC, serached the whole AppData\Roaming folder and don't see idea.jdk. I'd love to find and delete that and experience excellent results.

 

 

0
Comment actions Permalink

Brian

On Windows it's either idea.jdk file or environment variable, please see if you have any set: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879.

0
Comment actions Permalink

Brian

it should be in the following path: Users\<user>\AppData\Roaming\JetBrains\IntelliJIdea2020.3

0
Comment actions Permalink

Thanks Serge, same worked for me with PHPStorm; deleting /Users/<user>/Library/Application Support/JetBrains/PhpStorm2020.3/phpstorm.jdk

0
Comment actions Permalink

the new java (version "15.0.1" 2020-10-20)
does not understand 
-XX:+UseConcMarkSweepGC

specified on Linux in

~/.config/JetBrains/IntelliJIdea2020.3/idea64.vmoptions

 

needed to remove -XX:+UseConcMarkSweepGC from the idea64.vmoptions file

0
Comment actions Permalink

For PyCharm I needed to remove /Users/<user>/Library/Application\ Support/JetBrains/PyCharm2020.3/pycharm.jdk

0

Please sign in to leave a comment.