Debugger not working in newest Pycharm version

I updated to the latest version a few days ago. I feel that I have used the debugger since then, but I am not 100%. I cannot think of anything else that would have changed to cause this error.

First I got this error:

Plugin error: Plugin 'BashSupport' (version '') is not compatible with the current version of the IDE, because it requires build 191.* or older but the current build is PC-203.5981.165

I looked in the plugin menu and it does indeed show a red warning that:

"Incompatible: requires IDE build 191.* or older"

Additionally I see:

News for users of 2019.2 and later: JetBrains is bundling a new Shell plugin with 2019.2. You shouldn't use BashSupport and Shell simultaneously. Make sure to disable one of them. BashSupport supports more advanced features. Shell is more robust and providing better integration of basic functionality.

It seems I have the "Shell Script" Plug-in and it is active. When I try deactivating BashSupport and running the debugger. It simply skips over the breakpoint and runs the script to the end.


Mac Os Catalina 10.15.7

PyCharm 2020.3 (Community Edition)
Build #PC-203.5981.165, built on December 1, 2020
Runtime version: 11.0.9+11-b1145.21 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.15.7
GC: ParNew, ConcurrentMarkSweep
Memory: 1981M
Cores: 8
Non-Bundled Plugins: com.alayouni.ansiHighlight, com.intellij.ideolog, com.jetbrains.plugins.ini4idea


How can I fix this to be able to use the debugger again? Thank you



(BashSupport developer here)

If the Python debugger isn't working for  you anymore, then the messages about BashSupport is unrelated to this. It's just a coincidence.

If this is about debugging shell scripts, then only BashSupport Pro implements that. Legacy BashSupport or the JetBrains Shell plugin don't have this feature. Unless you had BashSupport Pro installed before, I'm not sure how the debugger worked for you previously.




I get the exact same error (Bash and debug),

Can't debug - meaning, remote debug works up to the checkpoint, but then all other options don't work (Step Over, Step Into,..., Evaluate Expression)

Tried to restart computer/pycharm/indexing, nothing works.

The only different thing I did this time is to update pycharm using the internal "update" option instead of deleting it and downlowding the newest version.

Please help,



Hi Shir,

Please file an issue to and provide screenshots showing the issue.


Please sign in to leave a comment.