Intellisense in IntelliJ no longer working

Answered

I'm currently running IntelliJ IDEA 13.1. While running IntelliJ 13 intellisense/autocomplete stopped working. I tried upgrading and it still doesn't work.

I can explicitly invoke code completion using ctrl+space. I looked in Settings->Editor->Code Completion and nothing looks out of place. Is there somewhere else that turns this feature on/off?

 

Walgreenslistens

0
3 comments

Hi,

Try the File | Invalidate Caches & Restart menu option.

Also see if disabling all downloaded plugins under File | Settings | Plugins | Installed and restarting the IDE helps.

General troubleshooting steps for problems with code completion:

1

I had the same problem. I solved it using these steps:

1. Go to Filte\Project Structure\Project

2. Change the used SDK with another one (I also had a kotlin one) and press "Apply changes"

4. Select back the sdk you want to use and press "Apply changes"

After these steps, the Intellij worked

0

I had this same issue after updating the value for the JDK being used by Maven (Settings -> Build, Execution, Deployment -> Build Tools -> Maven -> Importing).  I had to do that because I was getting the "Cannot Reconnect" error when Maven was trying to import.  Changing that JDK value seemed to fix the Maven issue but then Intellisense stopped working.  I reverted that change, did a Maven reimport, and everything was back in working order.  

0

Please sign in to leave a comment.