Ctrl+C, Ctrl+V removes spaces in expression

Hello, I searched in Help but just could not find answer on my question about copy-paste functionality and automatic format.

So, I copy to clipboard "c = a * b" and next line I paste it from clipboard --> it puts "c=a*b" every single time --> so I have to put spaces back manually. What is wrong? I like auto code ident what I type but I want that PyCharm keeps the format in the way I like.

(In Settings Editor --> Editor --> CodeStyle I cleaned almost all checkboxes).

Could you please advise me where is another setting to stop apply auto format on insert?

Thank you!

2 comments
Comment actions Permalink

Do you have any custom plugins installed?

Try File | Manage IDE Settings | Restore Default Settings...

Also, you may try Paste as Plain Text shortcut:

0
Comment actions Permalink

it is a fresh installed PyCharm. Could be that there are a few plugins that come together in an installation package because I did not install any extra plugins.

The proposed solution with "Keymap" and reassignment a keystroke helped me. I see that Ctrl+V was used by plugin "Terminal".

Thank you! Question is solved.

0

Please sign in to leave a comment.