PyCharm needs local configured Python SDK

I'm developing Python using Windows with Windows Subsystem for Linux (Ubuntu). While everything compiles, all of the docstrings say:

"You need a configured local Python SDK to render docstrings."

Using 3.8 @ Ubuntu (configured for current and new projects) in PyCharm and have 3.9 installed on Windows. Running the program from Windows with the interpreter set in Ubuntu. Please advise.

 

1 comment
Comment actions Permalink

Hello, 

>have 3.9 installed on Windows.

Please add the local interpreter to the PyCharms configuration.

See the comment on this from the responsible developer https://youtrack.jetbrains.com/issue/PY-18329#focus=streamItem-27-1568906.0-0

Unfortunately, there is no workaround.

Should you have any questions please let me know.

0

Please sign in to leave a comment.