the action of loading data source when open the datagrip takes too long every time

Every time I open my datagrip the background job runs for loading data source takes long time to finish. 

During this time I can't execute any SQL statement.

Is this nromal ?

Please help.

Thanks a lot!

7 comments
Comment actions Permalink

how many data sources do you have in a project?

0
Comment actions Permalink

Hi Yuriy, thanks for your reply.

I have three datasource on remote clound and three sap hana datasource.

I encountered this problem for version 2021.2.4. I degraded to 2021.1.3 then the problem sovled.

But there are still another performance issue. Both version takes long time when I clicked "refresh" on SAP HANA datasource.

0
Comment actions Permalink

File -> Invalidate cache could help after update to make IDE start up faster, please try it.

And introspection process depends on database size (objects amount), so if you DB is quite big then it will take some time.

0
Comment actions Permalink

I also have this issue, i only have a few data sources but they can have hundreds of tables each. DG will try to introspect every one of them before i can even see my data, i usually only want to look at a single table. This can take 10 minutes.

1
Comment actions Permalink

Jleagle

Could you describe your environment?
Also, invoke Diagnostic Refresh action and send us logs or create a new issue in DataGrip bug tracker

0
Comment actions Permalink

Hi team,

I have a similar issue (using PhpStorm on Linux, Build #PS-222.3345.135, built on July 28, 2022). In previous versions of PhpStorm, I have been able to stop this process, and just manually refresh the schema I am interested in, but this option appears to have been removed.

I understand that inspecting these DBs is likely to take time (especially if they are remote DBs with lots of schemas), so I'm not concerned that this is necessarily a performance issue, but it would be nice if either this could be optional, or could be done in a way that avoids locking up all DB access until it has finished. NB, I have disabled Introspection > Auto sync, on the source, and this appears to make no difference.

Thanks,

Ollie L

1
Comment actions Permalink

Same situation for me.  I have an AWS DocumentDB, 5 AWS RDS Sql Servers (each with up to 15 databases all containing hundreds of tables), and an AWS RDS Postgresql data source.  Every time I start up they refresh.  Most end up timing out because I have to be on different VPNs for different ones.  I'm not asking for the data source introspection to go away, I really like this feature.  I would just like to be able to control when it happens.  I know this won't be a popular statement, but something similar to how SSMS lets you register a data source but doesn't actually connect to it or introspect it until I request it do so, is, in my opinion, a better solution.

0

Please sign in to leave a comment.