PhpStorm 2022.2.2 cannot re-open existing project-dir


I have a strange problem running PhpStorm 2022.2.2 on Linux I cannot re-open existing project-dir. I already tried deleting the .idea-folder in the project dir, but even trying to create a new project from existing files doesn't open a new project-window! I already have two open projects but there's no additional window appearing and no message telling what's wrong as well.

Is there some cache/state file in ~/.PhpStorm2019.3/config/ which may be broken? I don't want to delete all my settings to start from scratch :-(


Additional note:
I also tried deleting this cache-files (having phpstorm exit before). After starting phpstorm the problem isn't resolved at all.
rm -rf ~/.cache/JetBrains/*

Trying to reopen the project-dir which doesn't open, a new .idea folder is created but there is no project-windor appearing by phpstorm.

I checked the idea.log after trying to open the project multiple times now and got this:

2022-09-20 12:27:28,230 [ 302673] WARN - Bash Cmd - get data from [/var/www/my-project-dir/bash_cmd_plugin/personal/bash_cmd_toolbar.json] is error: /var/www/my-project-dir/bash_cmd_plugin/personal/bash_cmd_toolbar.json (Datei oder Verzeichnis nicht gefunden)

What's wrong?!


I also tried uninstalling bash-cmd plugin. Also not working after that.

But fun-fact... opening the project parent-dir (which in that case is the customer-root for my customer's projects) works!

Opening the project-dir underneath doesn't work and phpstorm simply doesn't react or show a new project after asking me to open it in current window or a new one dialog.



Please try to delete "window.state.xml" file from "<configuration>_dir\options":

If the issue is still there after that, then please try remove the workspace.xml from the project folder.


Please sign in to leave a comment.