Updating SSH Interpreter copies all files

Answered

Whenever I change the SSH interpreter it copies all files from my laptop to the machine I ssh into. How do I disable that?

6 comments
Comment actions Permalink

You can disable the automatic upload in Preferences | Build, Execution, Deployment | Deployment | Options -> Upload changed files automatically...

0
Comment actions Permalink

That does not stop PyCharm from uploading after having changed the interpreter.

0
Comment actions Permalink

This could be it. I am running that version.

0
Comment actions Permalink

Try disabling Help | Find Action | Registry... and restarting PyCharm to confirm. Does it help?

0
Comment actions Permalink

I'm sorry, I already downgraded to 2022.1.4 where the problem does not occur.

0

Please sign in to leave a comment.