Configure system interpreter not working

Answered

I reinstalled pycharm and configurated the system interpreter. I have anaconda installed.

I tried to follow: https://www.jetbrains.com/help/pycharm/configuring-local-python-interpreters.html .

I did: File -> Settings -> Project: pythonProject -> Python Interpreter -> something like "C:Users\anaconda3\envs\pythonProject\python.exe . After doing this, this direction appears on "Python Console", but not on Terminal.

Then I wrote on Console, "import pandas as pd" and I obtain "No module named pandas".

So I decided to try another Interpreter "C:\Users\AppData\Local\Programs\Python\Python310\python.exe". But the same thing happens. What am I doing wrong?

Windows 10

3 comments
Comment actions Permalink

If you don't have pandas installed on those interpreters, then the error you get is expected. You can install it using PyCharm's interface https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-upgrading-packages.html

1
Comment actions Permalink

You're right. Thank you. But I look to my terminal, and it has written ">>>" when I think it should have something like "C:\Users\... >". Is there something wrong in the terminal?

0
Comment actions Permalink

Already solved the problem. Thank you!

0

Please sign in to leave a comment.