"Apropos" terminal pops up when typing cmd+shift+A to get actions bar

已回答

Everytime I type cmd+shift+A to pop up the Actions menu to search for an action a yellow terminal window pops up instead. I can't even type anything, but it says it's a terminal window. This means I can't search for the action I was trying to get to.

It doesn't always say the same thing, it doesn't always happen (though most of the time it does these days), it doesn't matter what project I'm in and I have no idea why it pops up. Any idea what setting I may have triggered? It's stopping me from being able to use the action search.

A workaround I seem to have found it doing cmd+O and tabbing to actions but that's not ideal since that's several more character strokes and I don't have that on muscle memory except when actually thinking about doing a class search!

Here's a screenshot of what I'm talking about. 

评论操作 固定链接

This was happening before updating to 2019.1 and continues even after updating. 

3
评论操作 固定链接

Say thanks to Apple for adding this shortcut, see https://youtrack.jetbrains.com/issue/IDEA-209726 for the workaround.

It has nothing to do with IntelliJ IDEA update. The issue is caused by macOS update.

59
评论操作 固定链接

I figured it out. I guess my latest Mac update added a new keyboard shortcut. Go to keyboard and disable that CMD+Shift+A shortcut...

I thought that at first but that shortcut wasn't do anything outside of IntelliJ. 

32
评论操作 固定链接

Thanks Serge, just saw your update. That worked +1

1
评论操作 固定链接

Thanks Serge !!!!!!!!!!!!!! That worked for me ! It made me crazy ! +1

1
评论操作 固定链接

I love you guys. It was realllllllllllllllllly annoying.

3
评论操作 固定链接

Thank you for a workaround! Super obnoxious

1
评论操作 固定链接

Thank you very much "Serge Baranov" & "Ryan Z Khalil" for solution !!!

1
评论操作 固定链接

Thanks, that was driving me crazy too! :)

0
评论操作 固定链接

Thanks Serge !!!!!!!!!!!!!! 

You saved my life ~ 

0
评论操作 固定链接

Thanks Serge! Made my day :)

0
评论操作 固定链接

After restore keyboard defaults on mac high sierra it just resolved the problem (pycharm 2019.1.3)

1
评论操作 固定链接

You can disable this shortcut in mac options:

4
评论操作 固定链接

Thanks @Mkaflowski .In case anyone comes across this issue and wants the English version of the above screen grab:

4
评论操作 固定链接

Thanks a ton. It worked for me

0
评论操作 固定链接

Glad this has been documented and resolved, it was driving me crazy

1

请先登录再写评论。