Idea 2019.2EAP losing the cursor in the editor

已回答

About 5 times a day, Idea just loses the cursor. While working in the editor, the cursor will suddenly disappear. Focus remains on the editor window, although there is no cursor visible and keyboard input is mostly ignored.

If I use the cursor keys, I can move around in the editor, which is identifiable by the current piece of code that is currently highlighted, i.e. I can move the highlight to the next variable or method by pressing the right-arrow key.

IU-192.5281.24, JRE 11.0.3 12-b304.2x64 JetBrains s.r.o, OS Linux(amd64) v5.0.0-19-generic, screens 1680x1050, 1680x1050

 

Has anyone else seen this?

5

Hello Adam,

Please check whether the following workaround helps:
1. Press `Help | Edit Custom Properties...` (if a dialog appears, press "Create")
2. "idea.properties" file will open. Add `suppress.focus.stealing=false` to a new line
3. Restart IDE

3

OK, done.

I'll give it a day or so testing - fingers crossed.

0

Hi Arseniy,

I can report that the frequency of the lost cursor issue has dropped a lot, but it is still happening.

i.e. it didn't happen at all yesterday, but it just happened now.

Previously it was happening 5x as much.

Regards

Adam

0

Unfortunately, issues with focus have different occasions for many reasons. Next time when you face the problem, please, file a new issue and describe steps to reproduce: https://youtrack.jetbrains.com/newIssue

0

Since I upgraded to the version below I've been seeing the same behavior. There's no specific action - I'm just typing and then I have no cursor. It's possible that it's some specific point in the code triggering some background activity - e.g. closing ">" on a java ArrayList declaration.

Seems to happen at least 5 times a day possibly much more.

IntelliJ IDEA 2019.2.3 (Ultimate Edition)
Build #IU-192.6817.14, built on September 23, 2019
Licensed to Michael Douglass
Subscription is active until May 29, 2020
Runtime version: 11.0.4+10-b304.69 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.15.1
GC: G1 Young Generation, G1 Old Generation
Memory: 2000M
Cores: 16
Registry: ide.mac.file.chooser.native=false
Non-Bundled Plugins: Amazon EC2, com.alayouni.ansiHighlight, com.intellij.ideolog, com.thoughtworks.gauge, org.asciidoctor.intellij.asciidoc, org.exbin.deltahex.intellij, org.jetbrains.plugins.localization, org.jetbrains.plugins.rest, com.dmarcotte.handlebars, com.intellij.plugins.html.instantEditing, com.jetbrains.php, AWSCloudFormation, Pythonid

0

Mikeadouglass,

Could you try upgrading to version 2019.3? https://www.jetbrains.com/idea/download/

It includes some fixes for similar problems when caret disappears from the editor.

In case you'll face similar issue on 2019.3, try modifying custom properties:

1. Press `Help | Edit Custom Properties...` (if a dialog appears, press "Create")
2. "idea.properties" file will open. Add `suppress.focus.stealing.active.window.checks=true` to a new line
3. Restart IDE

Please, write on whether that helps.

1

still seeing this annoying issue in 2019.3.3 (community edition)
this thread is not active, wonder if only I am seeing this issue or it does not bother people :-)

this does not help.

`suppress.focus.stealing.active.window.checks=true`

1

I'm experience this issue too. I'm using 

IntelliJ IDEA 2019.3.3 (Ultimate Edition)
Build #IU-193.6494.35, built on February 11, 2020
Runtime version: 11.0.5+10-b520.38 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.15.3
GC: ParNew, ConcurrentMarkSweep
Registry: debugger.watches.in.variables=false, compiler.automake.allow.when.app.running=true, js.debugger.webconsole=false
Non-Bundled Plugins: BashSupport, FrameSwitcher, IvyIDEA, Lombook Plugin, org.jetbrains.plugins.localization, Pythonid, com.dubreuia, com.google.bamboo.id, com.indeed.clippyivy, com.intellij.plugins.html.instantEditing, com.jetbrains.upsource, io.protostuff.protostuff-jetbrains-plugin, org.apache.pig.plugin.idea, org.jetbrains.kotlin, reasonml, ru.adelf.idea.dotenv

1

I am experiencing this every time I use the intellisense feature. As soon as the popup closes, my cursor becomes invisible and I can't type anymore. I can move the invisible/broken cursor around with the arrow keys, but cannot type until I click on the text with my mouse. This is happening for me on the latest release, EAP, and nightly build.

 

GoLand 2020.1 EAP
Build #GO-201.6073.28, built on March 6, 2020
GoLand EAP User
Expiration date: April 5, 2020
Runtime version: 11.0.6+8-b765.1 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.18.1-1.el7.elrepo.x86_64
GC: ParNew, ConcurrentMarkSweep
Memory: 964M
Cores: 4
Registry: run.processes.with.pty=TRUE, ide.completion.variant.limit=500, suggest.all.run.configurations.from.context=true, ideFeaturesTrainer.welcomeScreen.tutorialsTree=TRUE

Current Desktop: Undefined

0

Hi Nittanymountain,

There's plenty of known focus issues. What OS do you have? If Linux, what's your desktop environment?

0

Hi Shengpeng,

Could you describe any particular steps to reproduce?

0

Hi Shadoninja

What desktop environment do you have?

It seems you're facing https://youtrack.jetbrains.com/issue/JBR-1822

Could you confirm that?

1

Hi, Arseniy Nisnevich

You can trigger it by

  1. open an intellij window with any project. (you should be able to type in file editor or terminal, the focus is here correctly, make sure Intellij window is small enough so that you can see other applications in your screen, or better put some applications in another screen)
  2. click on some other application on your desktop with your mouse, in current screen or another screen, such as Chrome.
  3. click back in Intellij. You won't be able to type!

It's worth mentioning that after step 3, if I use command+tab to switch out to an application on the same screen (application in another screen doesn't work), and then switch back, I can type again.

It's quite annoying. Please prioritize this issue. Thank you!

0

Shengpeng,

Thank you for details. It's known that this issue appears when using Synergy: https://youtrack.jetbrains.com/issue/IDEA-215477

It this your case? If yes, please, vote and follow for updates. If you aren't familiar with YouTrack, see https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications

In case if you don't use Synergy, please, file a new issue and provide this information if possible.

0

Oh...Arseniy Nisnevich I am using Synergy.

I'll try something else then. Thank you for your reply!

0

Arseniy Nisnevich, Yes, the bug you linked is the exact problem I am having. There has been no workaround found in that bug tracker and it makes Intellij completely unusable. I tried different versions, settings, and reboots for a couple hours and eventually just reverted my VM back one month to a time before the problem and that fixed it. It has not come back either, so I will just leave my Goland on the current version until a fix is found.

0

I have this constantly. A quick workaround is to tab shift twice in a row. That wil make search appear and get the cursor back.

5

Same issue when using the IDE through a remote session. Very rarely when using it locally.

0

Hi,

We will need more details to investigate and fix the problem. Could you please file a new issue and provide this information? If you notice some steps that cause the issue, please mention them also.

0

still the same problem is happening

0

Hi Hjine1203

We are going to need more details to investigate and fix the problem.

Could you please file a new issue and provide this information? If you notice that certain specific steps cause the issue, please mention them too.

0

I am also having this problem of the cursor disappearing when within an editor window when I'm using Rider in a remote configuration (ShadowPC). Is there any work around for this issue yet?

0

Blue Williams

Try the solution suggested here: IDEA-215477. You can find it in the description of the issue at the very top.

If it doesn't help, try the latest version of the IDE 2022.3 EAP.

0

请先登录再写评论。