When running tomcat in IntelliJ 2019.2, the cursor is focused on editor every few seconds

已回答

There are no breakpoints being hit, and I've unchecked "Focus application on breakpoint" but still every few seconds the cursor refocuses on the editor, regardless of what application the server is in, when I revert to 2019.1.3, I don't experience this same issue.

评论操作 固定链接

Can you provide a screencast of the issue? 

As a possible solution, try to disable experimental `suppress.focus.stealing` feature: 

  1. Open Find Action... ("Ctrl-Shift-A" on Windows and Linux, "Cmd-Shift-A" on macOS)
  2. Type "Registry...", press Enter
  3. Find the key suppress.focus.stealing (just start typing to use speed searching) and disable it
0
评论操作 固定链接

Thanks for quick response, unfortunately I'm still experiencing the same issue after disabling that option. Have attached a screencast here - https://drive.google.com/open?id=1cvmDcactHsfgx7Vm9_EBDxrHxeHBQhfK .

0
评论操作 固定链接

Hello Andrew,

Does the issue happen when you run, but not debug Tomcat?

0
评论操作 固定链接

Hi,

It appears to only be an issue when in debug

 

0
评论操作 固定链接

This is a known issue: https://youtrack.jetbrains.com/issue/IDEA-220269

It appears when class reload on frame deactivation is enabled: https://www.jetbrains.com/help/idea/updating-applications-on-application-servers.html

Please, vote and follow for updates. If you are not familiar with YouTrack, see https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications

0

请先登录再写评论。