Debug tox with breakpoint doesn't work

Answered

PyCharm 2016 supports tox, which is good. But breakpoint doesn't work when debugging tox tests. What I see is tests running till the end and never stop at breakpoints I set.

Is this feature not implemented or I did something wrong?

6 comments
Comment actions Permalink

I have this same issue. They created a new ticket for me since PY-19086 is not the same issue apparently. You can track the issue that was opened for me here: 

https://youtrack.jetbrains.com/issue/PY-31539

Please feel free to leave a comment with your issue as well. 

Thanks!

0
Comment actions Permalink

I have the same issue but only in PyCharm 2018.3, in 2018.1 everything works fine for me, maybe it helps...

I want to move to the new version, but I can't because of this issue.

0
Comment actions Permalink

Does any of the above mentioned issues correspond to your problem? If so, please feel free to leave a comment and follow for updates.

0
Comment actions Permalink

The above linked tickets are separate issues -- they describe Tox Debug throwing errors or hanging indefinitely.

The problem described here, which I am also experiencing, is that Tox Debug simply does not respect breakpoints. It spins up pydev and runs all the tests, but breezes right past any breakpoints set in the test modules.

I'm experiencing this with PyCharm Community 2019.1

1
Comment actions Permalink

Ignoring breakpoints are covered by https://youtrack.jetbrains.com/issue/PY-17928 I believe. Reproducible for me as well in 2019.1.2.

0

Please sign in to leave a comment.