Command line tools doesn't work with unicode


I cannot use the command line tools inside directories that contain swedish letters, is there any way to change this?

I have unicode in my terminal settings so there shouldn't be any problems there. See picture below for what popup i get.


Could you please share a bit more information about the issue (possibly some additional screenshots)?
Are you trying to run the IDE from the command line? What kind of command line tools are you trying to use? Could you share the console output when the IDE fails to start?


Hello Ivan, 

This problem persists in every kind of command line i try to run it from, it seems to me that it somehow changes utf-8 encoded characters into latin-1 before attempting to run the script which is when i recieve the error message in my first screenshot. I have checked all my zsh language files and they all seem to be swedish utf-8 so i dont think that is the problem. I also got responses from reddit regarding this and someone using linux said this wasn't a problem for them so might be mac related. 

My current fix was to just rename all my folders to not contain any swedish characters. Down below is another screenshot of this, please let me know if there is anything else you need.


Thank you for the additional information.

Could you try to copy the existing idea.vmoptions file from the IDE installation directory (e.g. /Applications/CLion<version>.app/Contents/bin) to the IDE configuration directory, and add the following options:


I tried adding it but i still get the same results as before

Thanks for reporting this issue.

This is a bug and I can reproduce this issue too.
I have created a bug report here:
Please vote it for updates.
See if you are not familiar with our issue tracker.

Please sign in to leave a comment.