Mac users - Do you face high cpu and heating up during indexing?

When I open a project and PhpStorm starts indexing it, its CPU usage as reported by iStat Menus goes above 200% and temperature reaches 80 degrees Celsius. The fans run at full speed for the next couple of minutes, depending on the size of the project. It's pretty wild and concerning. The temp usually stays between 45-65 degrees when I'm working. 

I understand I'm going to see some hiccups when it's indexing a project, but is this much CPU usage and heating normal for Mac users? 

 

32 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

How large and complex is the project you are working with?

Where are the project files located?

0
Comment actions Permalink

Very small projects. Imagine a WordPress install with 5 plugins, 3 themes, and git.

On a MacBook Pro 13-inch, Mid 2014. 

Project files located in a /Users/username/Sites folder where my localhost Apache is configured to run.

0
Avatar
Vladimir Luchansky
Comment actions Permalink

That's strange indeed.

What PhpStorm version do you use?

Do you have any external monitors?

0
Comment actions Permalink

I have the same issue with Idea 2016.3.X

Heating up the system while indexing, even for small Java projects.

 

0
Comment actions Permalink

Does CPU usage go down after an indexing?

Generally speaking IDE tries to utilize as much CPU as possible to minimize downtime caused by indexing.

1
Comment actions Permalink

Yep, goes down after indexing.  CPU usage of PhpStorm more than 200% lasting for a minute or two makes the MacBook extremely hot and noisy because of the fans running at full speed.

While I understand the performance benefits of quickly indexing the entire project when starting up, I just want to know if this is normal and faced by other users as well. 


0
Comment actions Permalink

I'm getting this too now. I have a new mac that has never gone over 60ºC, and I started a new Ember project and it's shot up to 67ºC (all I did was generate the project and then try to open it in PHPStorm).

Would it be possible to limit the CPU usage of the indexing feature? I love what the indexing feature allows me (and funnily enough I'm actually in Power Save mode and it's trying to do all this indexing) but I'd trade off for slower indexing for not overheating my computer (and my lap).

0
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello Matt,

Are there any 3rd-party plugins you have added into PhpStorm?

0
Comment actions Permalink

I have a late 2017 macbook pro, and my cpu get's ridiculously hot while indexing (95 degC.) 

Is there a way to set intelliJ and pycharm to only use 70% of cpu while indexing?

1
Comment actions Permalink

I also have a macbook pro 15 2017 year (top). Wild CPU heat. Please make it possible to limit the use of the processor, yet the technique is expensive and you do not want to break it.

Парни действительно жалко технику, на ноутбуке крайне сложно работать, при условии, что он топовый и покупался специально для разработки. При стандартной температуре cpu и чистоте работы вентилятора 2000 - 2500 оборотов (из 6000 макс), ноут вообще не слышно, а при работе в phpStorm обороты ниже 4000 вообще не опускаются, и крайне часто повышаются до 5000 - 5500, правда немного надоедает и жалко технику (((

Загрузка cpu от 100 до 500 %, работает конечно быстро, индекс хороший, но когда постоянно приходится пересобирать отдельные участки проекта, то каждый раз гонять индекс с 100% затратами ресурсов не хочется. Получает при частых проверках результата работы отдельных участков кода постоянно запускается индекс и как итог cpu постоянно нагружен, особенно усложняет если работаешь от батарейки. Есть режим экономии встроенный, но он убирает подсказки и подсветку, так что не подходит. Ограничить количество ядер или процент загрузки cpu было бы самое то. Спасибо!

2
Comment actions Permalink

It's not a PhpStorm issue - this problem comes to us directly from IDEA, and unfortunately currently there's no way to limit CPU load during indexing.
Please vote: https://youtrack.jetbrains.com/issue/IDEABKL-3806

0
Comment actions Permalink

I was facing the same issue on an angular project in my new mac pro and my solution is to run the project (npm start) from iTerm instead of directly inside the IDE terminal.

This makes huge difference to me.

0
Comment actions Permalink

The same issue, CPU is loading up to 500% when any of projects indexing (mac pro 2015 y.).

0
Comment actions Permalink

The overheating issue from Indexing is back!!!! Upgrade to Mac OS Catalina 10.15 (and even the update 10.15.1) cause the CPU and fans to go into takeoff mode (hint: really noisy)

Issue is definitely indexing.  It took 32 minutes to index - the culprit is the scratches directory (which I cannot find a way to exclude).  Why would anyone want to index scratches and how do we stop them.

UPDATE: CPU fan noise dropped with Catalina 10.15.2 and 10.15.3.  Indexing will increase the temp still, but not for as long.  The index issue isn't unique to JetBrains, also Apple apps cause the same problem when they are indexing like Apple Mail and Apple Photo.  The difference is they are one time indexing, not every time I load a project.  Still no word on turning off the indexing of scratch directory so I have deleted all my scratch files and that has sped up indexing and reduced time to load the project.  Hope it gets addressed soon because there are plenty of one-time test scenario code we need to write but don't really want to place in the structure of the project.  My current workaround is to create a scripts directory and then exclude indexing of that directory.

1
Comment actions Permalink

I am having this issue on Catalina as well. Both my Mac mini and iMac. It doesn't happen with any other application.

0
Comment actions Permalink

I am having this issue on Catalina as well. Both my Mac mini and iMac. It doesn't happen with any other application.

Does the CPU load go down after indexing completes? Also, how long does it take for indexing to finish?

0
Comment actions Permalink

Eugene,

yes - the CPU load does go down after indexing. It takes less than 5 minutes to index.

0
Comment actions Permalink

That's expected: we're trying to finish indexing as soon as possible utilizing all the available CPU resources. 

Once the project is indexed - it shouldn't go through a full re-indexing again: if you close & reopen the same project - the issue shouldn't occur

0
Comment actions Permalink

It doesn't seem healthy for the computer. I'd rather have the option to limit available resources. In Docker there is the option to select how many CPUs and memory to use.

0
Comment actions Permalink

@Parag, on the bottom right there’s a little icon you can click for syntax control. In there, you’ll see a power save mode checkbox which should reduce resource usage.

0
Comment actions Permalink

The power save mode doesn't help with indexing: it disables inspections & syntax checks.

As for the "health" of mac - short/medium periods of high CPU usage doesn't affect pc/laptop health in any considerable way. First of all they're designed to withstands those loads, secondly: our team & thousands of our users are using our products for several years now, often at much higher loads. 

0
Comment actions Permalink

Dmitry Tronin i here you describing that this is as expected, But frankly it not enjoyable to keep the laptop on my lap while running intellij. Justing doing code editing tends to heat up the macbook up to a point where i can feel it. Other IDEs do not do this even though they have fairly good auto completions and fairly good inspection by default. The powersaving mode makes the IntelliJ dumb with no smart auto completions and lack of quick fix which are provided by inspections.

0
Comment actions Permalink

Gayanper

I wasn't saying it's expected to have IDE constantly loading & heating your CPU. 

Did you try troubleshooting the problem you're experiencing? Please try disabling all custom plugins at Settings | Plugins > click on a gear icon > "Disable All Downloaded Plugins", restart IDE and check the issue after that. 

0
Comment actions Permalink

I will try disabling installed plugins. I only have few theme plugins and sonarlint. I did measure CPU temp and while IDE is running it keeps above 60c and when IDE starts and while indexing it goes up to 105c. Also invoking completions and smart completions cause the temp to jump up to 70c for short time.

I tried working on eclipse as well and in eclipse the startup was around 70c and other scenarios were between 55-60c most of the time.

0
Comment actions Permalink

Same things on:

- MacBook Pro 2016 2,6 GHz Quad-Core Intel Core i7

- 1 external 23,5-inch (1920 x 1080) monitor

- with no 3d-party plugins enabled

-  WebStorm 2020.2.1
Build #WS-202.6948.73, built on August 25, 2020
version: 11.0.8+10-b944.31 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.15.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1957M
Cores: 8
Registry: ide.windowSystem.autoShowProcessPopup=true, documentation.show.toolbar=true, ide.allow.merge.buttons=false, debugger.watches.in.variables=false, ide.tooltip.initialDelay=522
Max Heap Size: 2024

No Custom properties

VM Options:

```

-Xms128m
-Xmx2024m
-XX:ReservedCodeCacheSize=240m
-XX:+UseCompressedOops
-Dfile.encoding=UTF-8
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Djava.net.preferIPv4Stack=true
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Xverify:none
-XX:ErrorFile=$USER_HOME/java_error_in_webstorm_%p.log
-XX:HeapDumpPath=$USER_HOME/java_error_in_webstorm.hprof
-Dide.no.platform.update=true
-Dsun.io.useCanonPrefixCache=false
-XX:CICompilerCount=2
-Didea.plugins.path=/Applications/apps/WebStorm/ch-0/202.6948.73/WebStorm.app.plugins
```

Even after indexing is competed tº doesn't go lower then 75º ( mac is open and almost hang in the air) and the coolers are spinning "well" constantly.

0
Comment actions Permalink

@Volodymyr Mykhaliuk 

1) please disconnect external monitor and check if performance any better

2) please switch to "No antialiasing" for both IDE and Editor at Preferences | Appearance & Behavior | Appearance and check if it lowers the CPU load

3) please open Help > Diagnostic Tools > Activity Monitor and check if you have any dominant process there

0
Comment actions Permalink

Dmitry Tronin thanks, seems like there is an improvement. Will test more. There is no appearance problem even though it is disabled on MacOS.

0
Comment actions Permalink

PhpStorm 2020.2
Build #PS-202.6397.115, built on July 29, 2020
Runtime version: 11.0.7+10-b944.20 x86_64
macOS 10.14.5
GC: ParNew, ConcurrentMarkSweep
Memory: 2014M
Cores: 4
Registry: run.processes.with.pty=TRUE, debugger.watches.in.variables=false, js.debugger.webconsole=false
Non-Bundled Plugins: String Manipulation, org.jetbrains.erlang, io.pivotal.jasmine, de.espend.idea.laravel, ru.adelf.idea.dotenv

There is a 2020.2.1 available...kind of doubtful that fixes this, but I will check....after it completes indexing :)

 

EDIT: just updated to 2020.2.1...no joy ;(

0
Comment actions Permalink

First of all please try disabling all custom plugins at Settings | Plugins > click on a gear icon > "Disable All Downloaded Plugins", restart IDE and check the issue after that.

Does it stay on 300% after indexing finishes?

 

 

0

Please sign in to leave a comment.