14.1 - Not showing Local Changes

This seems to be broken in both 14.1 and 14.1.1.

I don't really know how to recreate this bug for submission but it is persistent. I have local changes in my maven project. The editor tab isn't blue, its not showing up in the changelist. I am doing a direct comparison with GIT Head and the differences are clearly marked. There is nothing for me to push from my local repo.

Windows 7
IJ 14.1.1
Maven 3
JDK 7

3 comments
Comment actions Permalink

Make sure Git root is set correctly in Settings | Version Control.

Check idea.log (https://intellij-support.jetbrains.com/entries/23352446) for errors.

Try deleting IDE system folder (https://intellij-support.jetbrains.com/entries/23358108) and refresh the changes after restart.

3
Comment actions Permalink

My problem was solved after deleted .idea folder in project. (2017.3 EAP)

4
Comment actions Permalink

A similar problem. Solved by deletion .idea folder AND <projectname>.iml in the project root. 

3

Please sign in to leave a comment.