DataGrip always asks for password for my local PostsgreSQL connection

Answered

Whenever I try to open any table in my local Postgres connection, DataGrip asks for password, saying:

"The specified database user/password combination is rejected:

[08004] The server requested passord-based authentication but no password was provbided"

And I always have to re-enter the password, even when "Remember" checkbox is checked. Also that password was specified while creating connection.

Meanwhile at my another computer I do not have such issue.

What can be the problem? Is it a bug in DataGrip or something wrong with my local Postgres configuration?

P.S. Now DataGrip started to ask for password only one time after I relaunch it. After that I can freely open tables.

13 comments
Comment actions Permalink

@Alexander Egorov Could you e-mail IDE logs to vasily.chernov@jetbrains.com and provide a screenshot of your "Appearance & Behavior > System Settings > Passwords" settings?

 

0
Comment actions Permalink

@vasily chernov

Sent you the files.

0
Comment actions Permalink

@ Alexander Egorov 
Thank you for logs.
It's the known issue https://youtrack.jetbrains.com/issue/IDEA-163275 .
As a temporary workaround you need to enable "Save passwords => In KeePass".

1
Comment actions Permalink

Unfortunately, KeePass works terrible in my case. Anytime I launch DataGrip and open any table for the first time - this operation takes a couple of minutes, all I see is a lagging spinner with the word "Processing". Also, when I change the password, this also takes a long time, sometimes making DataGrip irresponsive (but CPU load is low though). Seems all operations "through" KeePass take a long time.

0
Comment actions Permalink

Weirdly enough I just disabled remember password at Data Sources and Drivers , and it did not ask every time for pass. 

When I tried enabling remember pass back again, it kept asking for password again...

Try it out.

0
Comment actions Permalink

unselecting remember me works for me as well on datagrip. This is wierd.

0
Comment actions Permalink

I have found a solution ...

Go to Preferences -> System Settings -> Passwords ... and from there choose KeyPass for saving passwords

This will save passwords in a file so it should not have any problems in the future, the only bad thing is that since pass is saved in a file it can be less secure (but in my case I dont really care since all my servers are local)

 

 

 

1
Comment actions Permalink

Had the same problem with 2018.1 installation in MacOs. It has been working find until recently it started asking for password even though I checked "Remember Password"  and "Native Keychain" in Appearance & Behavior -> System Settings -> Password.

Like @Flaviorajta said, I unchecked "Remember Password" and filled the password and counter-intuitively, the problem is gone. 

1
Comment actions Permalink

To uncheck "Remember Password" saves the day. Thanks very much.

But maybe its a missunderstanding. "Remember Password" means "Remember to ask the password again and again" :-)

0
Comment actions Permalink

Same issue, Arch Linux KDE.

0
Comment actions Permalink

@ Evgeniy Tsvigun 
Coud you try to store your password is KeePass?

0

Please sign in to leave a comment.