control function keys (e.g. "cntrl F" for find) stop working


I need help fixing this.  Most key coimbinations that start with control key such as Control X, Control Z, Control D, Control F, etc. suddenly stop working.  There is nothing wrong with keyboard since the same combination works fine on other application.

Not sure what caused it. 




Please check if these shortcuts are assigned to actions in your Settings/Preferences | Keymap. Try setting it to default scheme.

If everything seem to be correct in Keymap settings, please rename/remove configuration folder to start with defaults


Hi Sergey, 

The shortcuts are defined in settings/keymap (though somewhat different from before, e.g. delete line was ctrl+X, now it is ctrl+Y. But that's is ok.

I renamed the config folder, restart the computer and start pycharm.  a new config folder was created.   But nothing's changed.  For instance the shortcut for find (defined in keymap as ctrl F), just jumps around.   What else can I try?

This problem happened very suddenly.  I couldn't figured out what the cause could be. 


I just realized that I did update perl plugin very recently.  So I tried disable it and that does the job!



I know it is an old issue, but wanted to highlight it because I had a similar issue. When using cmd + F, the "enter" button did not move to the next occurrence of the found string, it just stod still.

Disabling the Makefile plugin that I just installed was the culprit, and removing it solved my issue.  


Please sign in to leave a comment.