Alt-gr not working on PyCharm

Answered

Fellow programmers,

I am entirely unable to use the ALT-GR key, or even the CTRL+ALT combination into PyCharm, whenever I try to use it unless I'm in the terminal, where it works.

This sounds very strange to me and it's sending me crazy, because I'm unable to type any bracket, having an Italian keyboard.  

 

Thank you in advance,

Take care.

28 comments
Official comment

The problem is known https://youtrack.jetbrains.com/issue/IDEA-209426, please upvote and follow for updates.

 

See this comment for a temporary workaround https://youtrack.jetbrains.com/issue/PY-34816#focus=streamItem-27-3366765.0-0

I have the same issue and I don't know how to fix it.

0

I have got the same issue. I have got an Italian keyboard and I need the ALT GR key..

0

Hi Sergey,

Yes I have got the issue with the last version of 2019.1.

If I return to 2018.3 version, I have not got this type of problem.

1

Hi Sergey,

It has already been done.
Precisely, the problem appeared after the 2019.1 update;

4

I'm sorry but I already have 2019.1 version :(

2

Same issue here after upgrading from 2019.1 EAP. No more Python coding w/o a chance to enter [] or {} on my keyboard. Sergey, could you please elaborate on "switching IDE to run under 1.8 JDK"?

0

Same issue here with french keyboard since 2019.1 EAP

1

Same issue here with french keyboard after updating PyCharm. Resolved by changing JDK embeded in PyCharm to system JDK :

PyCharm -> Help -> Find Action... -> Entrer "switch" to find "switch IDE Boot JDK" :

 

EDIT : Unckecked "actionSystem.fix.alt.gr" in PyCharm registry works. Thanks Josip !

 

EDIT 2 : Updated PyCharm today, ALT+GR doesn't work anymore, had to check "actionSystem.fix.alt.gr" + restart to make it work.

9

I confirm that swiching to JDK1.8 solves the problem.

5

Confirmed.

Problem solved with the IDE Boot JDK switch, thanks for helping us!

2

Updated today to PyCharm 2019.1. Had the same problem and fixed it by changing registry

In PyCharm click Ctrl + Shift + A. Then write registry and click on it. Find actionSystem.fix.alt.gr and uncheck it.

Then it should work (at least it did for me)

17

Unchecking actionSystem.fix.alt.gr also works for me with JB JDK1.11

1

Unchecking actionSystem.fix.alt.gr works like a charm ... Sweet!

1

Thanks Josip Komljenovic

Unchecking actionSystem.fix.alt.gr in Registry works for me

1

If anybody else is still stuck on this, for me unchecking actionSystem.fix.alt.gr didn't work, but unchecking actionSystem.win.suppressAlt did the trick.

0

Another one with the same problem after updating PyCharm. The registry fix worked :) Thanks!

0

Hi :-)! The switch to Java 1.8 fixed for me too. Thanks for the solution!

1

Latest PyCharm update (PC-191.6605.12) fixed the problem "for good".

0

I am a bit confused. I have the latest PyCharm Version and sometimes "alt gr" stops working during a session. What are the defaults in the registry? Assuming that non default values are highlighted in bold blue font, I have:

  1. actionSystem.fix.alt.gr checked (default)
  2. actionSystem.force.alt.gr checked (non default)

If I uncheck the force option, alt gr stops working.

 

Version info:

PyCharm 2019.1.1 (Professional Edition)
Build #PY-191.6605.12, built on April 3, 2019
JRE: 11.0.2+9-b159.34 amd64

0

Like Alexlampe I had to check force.alt.gr. It doesn't matter what I set fix.alt.gr to be; therefore I left it at the default (checked) setting. Same version but community edition.

0

Thx @Elifgsavukcam 

All the others didn't work, but yours did.

Just check actionSystem.force.alt.gr and that worked instantly without restarting anything

0

Hello, switching to Zulu OpenJDK 1.8 also solves the problem in macOS Mojave.

0

Please sign in to leave a comment.