"Apropos" terminal pops up when typing cmd+shift+A to get actions bar

Answered

Everytime I type cmd+shift+A to pop up the Actions menu to search for an action a yellow terminal window pops up instead. I can't even type anything, but it says it's a terminal window. This means I can't search for the action I was trying to get to.

It doesn't always say the same thing, it doesn't always happen (though most of the time it does these days), it doesn't matter what project I'm in and I have no idea why it pops up. Any idea what setting I may have triggered? It's stopping me from being able to use the action search.

A workaround I seem to have found it doing cmd+O and tabbing to actions but that's not ideal since that's several more character strokes and I don't have that on muscle memory except when actually thinking about doing a class search!

Here's a screenshot of what I'm talking about. 

18 comments
Comment actions Permalink

This was happening before updating to 2019.1 and continues even after updating. 

3
Comment actions Permalink

Say thanks to Apple for adding this shortcut, see https://youtrack.jetbrains.com/issue/IDEA-209726 for the workaround.

It has nothing to do with IntelliJ IDEA update. The issue is caused by macOS update.

57
Comment actions Permalink

I figured it out. I guess my latest Mac update added a new keyboard shortcut. Go to keyboard and disable that CMD+Shift+A shortcut...

I thought that at first but that shortcut wasn't do anything outside of IntelliJ. 

30
Comment actions Permalink

Thanks Serge, just saw your update. That worked +1

1
Comment actions Permalink

Thanks Serge !!!!!!!!!!!!!! That worked for me ! It made me crazy ! +1

1
Comment actions Permalink

I love you guys. It was realllllllllllllllllly annoying.

3
Comment actions Permalink

Thank you for a workaround! Super obnoxious

1
Comment actions Permalink

Thank you very much "Serge Baranov" & "Ryan Z Khalil" for solution !!!

1
Comment actions Permalink

Thanks, that was driving me crazy too! :)

0
Comment actions Permalink

Thanks Serge !!!!!!!!!!!!!! 

You saved my life ~ 

0
Comment actions Permalink

Thanks Serge !

0
Comment actions Permalink

Thanks Serge! Made my day :)

0
Comment actions Permalink

After restore keyboard defaults on mac high sierra it just resolved the problem (pycharm 2019.1.3)

1
Comment actions Permalink

You can disable this shortcut in mac options:

2
Comment actions Permalink

Thanks @Mkaflowski .In case anyone comes across this issue and wants the English version of the above screen grab:

2
Comment actions Permalink

Thanks a ton. It worked for me

0

Please sign in to leave a comment.