DataGrip 19.2 won't start after update

Answered

Ubuntu 16.10

After updating to 19.2 it gets stuck trying to reopen files and then throws "Failed to load default project". Tried to reinstall but didnt work and I dont want to delete files and lose my stored datasources

10 comments
Comment actions Permalink

Could you email me IDE logs vasily.chernov@jetbrains.com?

As a temporary workaround rename your .DataGrip%version% folder and start IDE

0
Comment actions Permalink

Could you try to reproduce the issue in DataGrip 2019.2.1?

0
Comment actions Permalink

I'm facing exactly the same issue after upgrade to DataGrip 2019.3 on Mac.

 

0
Comment actions Permalink

@Edgars,

Did you migrate settings from previous version?

0
Comment actions Permalink

I did.

I don't know how to cleanup settings and considering downgrade.

Thank you.

0
Comment actions Permalink

@Edgars ,

Could you email me IDE logs vasily.chernov@jetbrains.com?

0
Comment actions Permalink

I have mailed you log file.

From the log I can see that issue is related to GTM plugin (had similar issues with PyCharm), but compared to PyCharm I can't access preferences or other menu items to disable this plugin.

 

0
Comment actions Permalink

@Edgars,

Try to disable GTM plugin before launch. See https://intellij-support.jetbrains.com/hc/en-us/articles/206544519 for details

 

0
Comment actions Permalink

I have removed GTM plugin from ~/Library/Application Support/JetBrains/Toolbox/apps/datagrip/ch-0/193.5233.139/DataGrip.app.plugins/gtm-intellij.jar and now DataGrip starts correctly.

Thank you.

1

Please sign in to leave a comment.