Mouse is selecting the text by itself

Hi!

A annoying behavior happens when I click the editor at some character and just moves the pointer around, this makes a selection of the text. 

The expected behavior to select a text should be by pressing the left btn with the mouse and moving it around, but in my problem I don' t need to press it, it selects the text just by clicking and moving around. This only happens in pycharm, I already unplugged my mouse and nothing changed.

Any help? 

27 comments
Comment actions Permalink

Hello, 

 

What OS are you running? 

Could you please also attach your logs folder zipped from Help | Compress Logs and Show in…  and upload it to the FTP: https://uploads.services.jetbrains.com/  , please provide me with a folder name. 

 

Thank you! 

0
Comment actions Permalink

Hi!

It is a ubuntu 19. I rebooted the machine the next morning and everything was normal again. Probably I pressed some random keys cleaning the keyboard during initialization and made it behave like that.

The next time it happens again I will get the logs and send them to the ftp. Thanks for replying!

Felipe.

0
Comment actions Permalink

Hi, it happens the same to me.

I am using Ubuntu 18.04, and I uploaded my logs folder zipped, the folder name is pycharm-logs-20191209-111128.zip (109 kb)

Thank you in advance,

ana

0
Comment actions Permalink

@Anarucu

What is your desktop environment?

Would it be possible to provide a screencast demonstrating the issue?

0
Comment actions Permalink

I am having the same issue with Ubuntu 19.10 with the default desktop environment (gnome).

Is there an solution to this issue?

0
Comment actions Permalink

Hello, 

 

Could you please create a ticket at https://youtrack.jetbrains.com/issues/PY and attach a screencast presenting the issue? (please use a tool that also records the mouse actions)  And attach logs folder zipped from Help | Compress Logs and Show in…

Information on how to use YouTrack: https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications

0
Comment actions Permalink

In case you have a touch screen: try touching it once.

That solves the problem for me most of the times.

Are you running Wayland or xorg?

echo $XDG_SESSION_TYPE

Anyway: it might be related to this:
https://askubuntu.com/questions/143015/mouse-selects-everything-on-its-own

 

73
Comment actions Permalink

Had the same issue in ubuntu 19.10 - the problem was fixed by touching the touchscreen. However this never happened in IntelliJ that I have been using with ubuntu for over a year - but happened in clion?

13
Comment actions Permalink

Selection with Mouse is nightmare... Behaviour weird Pycharm  2020.1.3 (python language)...

It was getting worse every last updates... now it´s impossible to select a piece of code with mouse... because selection starts not in cursor place , and once dragging, suddenly unmark before unpress mouse button.

1
Comment actions Permalink

@Gastonscazzuso

Please report it to https://youtrack.jetbrains.com/issues/PY attaching your idea.log file from Help | Show Log in... and a screencast, if possible.

0
Comment actions Permalink

update:   logitech mouse CLICK button Problem !!!!! Left button was un-selecting during selections movements. I´ve tested with touchpad and it works perfect. Now new mouse and no more issues.!

Forgive me to ask Pycharm about this ! :) 

 

Hi Sergev !.....   

   Now i had disabled "MOVE code fragments with drag-and.drop" and it´s working much much better... i will test it one day more and i will let you now.

Tons of time this funcion activates alone (i am not pressing CTRL at all) but sometimes during mouse drag selection , Part of the selected text change location accidentally.

2
Comment actions Permalink

I would get into this state occasionally and it was driving me crazy.  I do have a touch screen on my workstation even though IntelliJ isn't running on it.  Once it got into that mode touching the touch-screen cleared it up.  I would never have come up with that solution by myself, so thanks for the info.

Because my pants fall down a lot I added the suspenders - disabled the Move code fragment too.

1
Comment actions Permalink

I have solved this problem by touching the screen. (my screen has touch screen option) 

 

@Javid Asgarov Thank you for your comment . 

14
Comment actions Permalink

I also had this happening in CLion on my ASUS ZenBook laptop (with touchscreen), but it helped to simply touch the screen as Javid Asgarov and Leel pointed out! Thank you, it was super frustrating to keep selecting things :|

0
Comment actions Permalink

Solution

1: Go to setting

2:search mouse

3: In editor action edit the Add rectangular selection on mouse drag

0
Comment actions Permalink

Thanks Javid Asgarov! As mentioned, touching the touchscreen solved the issue (using a Thinkpad X1 Carbon w/ touchscreen).

1
Comment actions Permalink

Thanks, that's was a nightmare for me, I had to restart the laptop ASUS FLIP S touch screen. Then I read the comments they said to touch the screen and I touched it, it's working fine. 

0
Comment actions Permalink

Same here, touching the screen solved my issue

0
Comment actions Permalink

For me I basically solved the issue by putting the mouse cursor off the window on the window bar(on top), moving and clicking a few times.

0
Comment actions Permalink

Same for me in a touch screen Dell XPS, touching the screen resolved the issue.

0
Comment actions Permalink

Unchecking "Move code fragments with drag-and-drop" in Preferences > Editor > General as suggested in https://intellij-support.jetbrains.com/hc/en-us/community/posts/360006400200/comments/360002028439 solved my issue, thank you!

0
Comment actions Permalink

Same issue with an XPS. Touching the screen used to fix it, but not anymore.

Rebooting is the only option. Really frustrating.

0
Comment actions Permalink

This problem is happening again linux 5.15. 

I have tried the following:

1. touching the screen

2. rebooting

3. reinstalling xorg-input-synaptics

The symptoms have slightly changed since 2020 when this issue first started happening.

Now the only way to interact with any window is through the touch screen, the trackpad is totally disabled.

It happened suddenly without any other apps open, from one moment to the next. So nice, given I'm working on a deadline. 

Pycharm team, can you please raise this in priority. 

0
Comment actions Permalink

I think I found one cause of same problem or at least of the annoying similar thing I had on my laptop. I tried to code/debug in that awful environment ignoring it for maybe 3 weeks. 

The issue as already stated above: Mouse hovering unintentionally, selecting , highlighting texts by itself, to the worse coding area starts sliding down/up and it couldn't be stopped. Output terminal started sliding up/down in the same way when mouse is over it.

Reinstalling pcharms didn't help.Touching the touch screen of laptop didn't help. Changing the settings of mouse/cursor on laptop and on Pcharm mouse settings didn't help. I tried the suggestions above, but didn't help either.

fix : I tried to remember how /when it started. It was after using extra 2 monitors. Could it be a coincidence ? Then I just unplugged the extra screens(or hub cable reaching to them), only having laptop screen, it WORKED, normal regular coding area back. Then I connected screens again and moved pycharm page there, it was normal and working nice.  I was so happy. I think this is still a bug and fixation might be a  temporary solution before it relapses. However, no problem so far. 

 

 

0
Comment actions Permalink

touching the screen once works for me!!!! This confuses me for a few days!!!  Thanks!

I am using ubuntu 22.04 on a dell laptop

0

Please sign in to leave a comment.