The required connection property does not found ClusterID

This confusing grammar appeared with Datagrip 2021.3.3 and Redshift driver version 2.1.0.1 [stable]

IAM permissions are set up correctly. Older versions of Datagrip using driver 1.2.16 work fine.  Username/password with the same host and port work fine. Only this "AWS Profile" (renamed from "IAM Auth" ?) fails with the odd grammar.

11:09 AM [99999] The required connection property does not found ClusterID

11:09 AM my-redshift.abc123.us-east-2.redshift.amazonaws.com
[99999] The required connection property does not found ClusterID.

 

My setup looks like this: (hostname edited). It also uses an SSH Tunnel to get into the VPC where the cluster is, again working fine with older version and working fine with username/password to the same cluster.

The error message does not change if I use invalid values for the user and IAM profile. 

9 comments
Comment actions Permalink

Checking the logs, I do see a successful SSH login on the tunnel bastion for each Test attempt, so it is setting up the SSH tunnel before failing...

0
Comment actions Permalink

Please upload logs from Help -> Collect logs and diagnostic data to our server https://uploads.jetbrains.com/ and provide me upload id.

0
Comment actions Permalink

That menu item is a no-op, it does nothing.

EtA: ...if the Data Sources and Drivers window is open. You have to close this window before that menu item works.

Upload ID is 2022_01_07_EwcLc7mbNYgCCWsN

0
Comment actions Permalink

@... this is really holding us back...

0
Comment actions Permalink

Hello I believe I am encountering this same problem. This is the first time I am trying to set up DataGrip and I cannot connect to Redshift using an AWS Profile or a Username/Password. I am on DataGrip 2021.3.4. I am connecting via an SSH (which completes successfully).

0
Comment actions Permalink

As far as I know there is no direct connection to serverless Redshift, so you need to connect via balancer or via ssh jump host.

0
Comment actions Permalink

> you need to connect via balancer or via ssh jump host.

If there is a way to connect via jump host, can you post instructions please?

0
Comment actions Permalink

I resolved this simply by using the "URL only" connection type, nothing else was required.

1

Please sign in to leave a comment.