The required connection property does not found ClusterID
This confusing grammar appeared with Datagrip 2021.3.3 and Redshift driver version 2.1.0.1 [stable]
IAM permissions are set up correctly. Older versions of Datagrip using driver 1.2.16 work fine. Username/password with the same host and port work fine. Only this "AWS Profile" (renamed from "IAM Auth" ?) fails with the odd grammar.
11:09 AM [99999] The required connection property does not found ClusterID
11:09 AM my-redshift.abc123.us-east-2.redshift.amazonaws.com
[99999] The required connection property does not found ClusterID.
My setup looks like this: (hostname edited). It also uses an SSH Tunnel to get into the VPC where the cluster is, again working fine with older version and working fine with username/password to the same cluster.
The error message does not change if I use invalid values for the user and IAM profile.
Please sign in to leave a comment.
Checking the logs, I do see a successful SSH login on the tunnel bastion for each Test attempt, so it is setting up the SSH tunnel before failing...
Please upload logs from Help -> Collect logs and diagnostic data to our server https://uploads.jetbrains.com/ and provide me upload id.
That menu item is a no-op, it does nothing.
EtA: ...if the Data Sources and Drivers window is open. You have to close this window before that menu item works.
Upload ID is 2022_01_07_EwcLc7mbNYgCCWsN
@... this is really holding us back...
Hello I believe I am encountering this same problem. This is the first time I am trying to set up DataGrip and I cannot connect to Redshift using an AWS Profile or a Username/Password. I am on DataGrip 2021.3.4. I am connecting via an SSH (which completes successfully).
As far as I know there is no direct connection to serverless Redshift, so you need to connect via balancer or via ssh jump host.
> you need to connect via balancer or via ssh jump host.
If there is a way to connect via jump host, can you post instructions please?
Fast googling shows the following ways:
I resolved this simply by using the "URL only" connection type, nothing else was required.
Can someone verify that logging into serverless Redshift works with "URL only" connection without ELB/Jump Box?
I tried with "URL only" and I wasn't able to get it working.
When I try with ConnectionType=URL only / Auth=User&Password with JDBC connection string from Redshift dashboard, then I am getting "The connection attempt failed"
When I try with ConnectionType=URL only / Auth=AWS Profile, Profile=MyProfile then also I am getting "[08001] The connection attempt failed"
When I try with ConnectionType=URL only/Auth=IAM then I am getting "Cluster default not found"
Is there any proven way/walkthrough to get this working?
Martin Macak,
Have you enabled public access to your serverless instance?

I have the same or very similar issue as the OP…
I'm on DataGrip 2026.2.2 connecting to Redshift. My Redshift is not available to the public.
Joseph Fitzgerald, please report this issue on our tracker, and we'll take a look.