Intellij IDEA is laggy

已回答

intellij idea is so lag for me that I can't even use it my CPU goes from 10% to 99% its not when I paste or type anything its lag when I click a button on mouse or just open intellij

 

anything I do on intellij my cpu uage goes up

 

评论操作 固定链接

Hi there,

Is the issue reproducible with all custom plugins disabled (File | Settings | Plugins | Installed | ⚙ | 'Disable all downloaded plugins') and IDE restarted?

Also make sure that:

  • IDE config directories, installation folder and project files are excluded from the antivirus/firewall scan
  • IDE is installed on a fast local drive and project files are not located on network drives

If the problem persists:

  1. Capture a CPU usage snapshot. To avoid unnecessary "noise", CPU profiling should be started only when you see performance degradation, and stopped immediately after testing.
  2. Take a screenshot of the Help | Diagnostic tools | Activity Monitor window while experiencing high CPU usage
  3. Zip the entire log folder (Help | Collect Logs and Diagnostic Data), then send everything over for analysis. You can upload the data privately to https://uploads.jetbrains.com/ and provide the upload id here.
1
评论操作 固定链接

i have no custom plugins installed

0
评论操作 固定链接

Aryiaxd

Then please follow the rest of the instructions to collect additional information for the investigation.

0
评论操作 固定链接

Upload id: 2021_12_08_HedBVBj4nkh5CKxd (file: IC-213.5744.223_Ariya_08.12.2021_12.48.16.zip)
this is my CPU usage snapshot

0
评论操作 固定链接

this is screenshot of my activity monitor

0
评论操作 固定链接

Upload id: 2021_12_08_QBxchjV3HvRep6kK (file: idea-logs-20211208-12544810036758827878687138.zip) and this is my intellij logs

0
评论操作 固定链接

Thank you. I'll analyze the data and get back to you.

0
评论操作 固定链接

Please disable the following custom plugin:

Loaded custom plugins: Dracula Theme (1.12.2)

Then restart the IDE to see if it makes a difference.

If it doesn't help, try increasing the maximum heap size to e.g. 2000 mb in Help | Change Memory Settings.

You can also try invalidating caches: File | Invalidate Caches | Invalidate & Restart

0
评论操作 固定链接

The snapshot shows usage spikes on loading plugins, some UI element rendering (specifically in the editor), and code inspection/highlighting.

What kind of project do you have? Is the problem specific to a single project or is it reproducible in every project, even a new simple Java one?

Please attach a new CPU snapshot (1-2 min long) and batch of logs after you've set Heap Memory size to 2000m and disabled the Dracula Theme plugin.

0
评论操作 固定链接

this is my new CPU snapshot

Upload id: 2021_12_10_KYTXjmTf72Z534YG (file: IC-213.5744.223_Ariya_10.12.2021_07.40.21.zip)

and this is my log

Upload id: 2021_12_10_Uh25Fsj12JnnnwVG (file: idea-logs-20211210-0742409203805196150557005.zip)

0
评论操作 固定链接

Thank you.

I filed a new performance problem report about it to our issue tracker:

Responsible developers will look into it. Feel free to follow the issue to stay updated on the progress.

Please also answer the questions from my previous message. It may help the investigation.

0
评论操作 固定链接

Does it help if you disable Grazie plug-in and increase -Xmx to 2048m in Help | Edit Custom VM Options? Make sure to restart the IDE.

0
评论操作 固定链接

i disabled Grazie and i changed heap size to 2048m

0
评论操作 固定链接

but my cpu usage is still high

0
评论操作 固定链接

my cpu usage is high in any project

 

0
评论操作 固定链接

What hardware do you use? What's the CPU/GPU?

0
评论操作 固定链接

my CPU is Intel(R) Core(TM)2 Duo CPU E8400 @3.00GHz

and my GPU NVIDIA GeForce GT 710

0
评论操作 固定链接

but why my CPU usage is going from 0 to 99%?

 

0
评论操作 固定链接

Hi, I have the same problem , today I have upgraded my PyCharm and now I cant work because the IDE UI is very laggy :((

PyCharm CPU load > 100% all time

PyCharm 2020 worked much faster, how to downgrade?

My configuration: 

Any solution?

Thanks

0
评论操作 固定链接

Aryiaxd Please share these 2 files, for some reason -Xmx2048m setting doesn't seem to be applied to the JVM.

C:\Users\Ariya\AppData\Roaming\JetBrains\IdeaIC2021.3\idea64.exe.vmoptions
E:\Programs\JetBrains\IntelliJ IDEA Community Edition 2021.3\bin\idea64.exe.vmoptions

You can attach the files at https://youtrack.jetbrains.com/issue/IDEA-284656.

0
评论操作 固定链接

Any update on this? I am experiencing same problem, tried disabling plugins, increasing heap space with no avail.

CPU usage spontaneously spikes up to 500% when I start typing. Only solution that worked was to downgrading to a lower version.

0
评论操作 固定链接

Thank you for your reply.

Unfortunately I have already downgraded to 2021.2.3 and am unable to report anytime soon.

0
评论操作 固定链接

Thank you Tsogtbileg Dash-Yondon.

Can't say much without the diagnostics data, so next time something like this happens, make sure to grab the logs.

0
评论操作 固定链接

Will do, thank you for your time and sorry for distracting you without having diagnostic data.

0
评论操作 固定链接

Aryiaxd

Further analysis of the logs and thread dumps suggests that slowness may be caused by hardware rather than software configuration.

Do you have HDD or SSD (or both)? Do drives C: and E: share the same data partition? Do you have any network drives in your system?

0
评论操作 固定链接

E:\Programs\JetBrains\IntelliJ IDEA Community Edition 2021.3\bin\idea64.exe.vmoptions

is
Upload id: 2021_12_15_6AejCS5Dzc3LQSWi (file: idea64.exe.vmoptions)

and
C:\Users\Ariya\AppData\Roaming\JetBrains\IdeaIC2021.3\idea64.exe.vmoptions

is

Upload id: 2021_12_15_XkMPzRqmnBiASd8H (file: idea64.exe.vmoptions)

0

请先登录再写评论。