Start Failed, Internal error: recovering IDE to the working state after the critical startup error

Symptoms

IDE shows the Start Failed dialog with the exception stacktrace and the following text:

Internal error. Please refer to https://jb.gg/ide/critical-startup-errors

Cause

There are multiple possible causes for this issue: broken or incompatible plug-in, corrupted IDE installation files, failed patch update, broken caches or damaged configuration.

It may be hard to guess the root case from the exception stacktrace.

Resolution

Please try the following steps one by one until the issue is resolved:

  1. In case of "java.nio.file.AccessDeniedException: ...plugins\github-copilot-intellij\copilot-agent\bin\copilot-agent-win.exe", please see this Copilot discussion and the corresponding issue.
  2. If you get "java.net.BindException: Address already in use: bind" exception, please refer to IDEA-238995 for the workaround.
  3. Delete the third-party plug-ins directory (idea.plugins.path in the user's home directory, depends on the OS and IDE version. Please be aware that default locations have changed in 2020.1 release). You can bisect the plug-ins to find the offending one and remove only that plug-in, keeping the working plug-ins.

    Note: if the installation is managed by the Toolbox App, plug-ins directory will be located next to the application install location which can be found from the Toolbox properties of the installed app. Look for the directory name starting with the build number and ending with the .plugins, like 192.5728.98.plugins.
  4. Download and install the IDE again, either from the official site or using the Toolbox App. Your settings and projects will be preserved. When installing from .tar.gz on Linux make sure to unpack into the new empty directory, not on the top of the existing installation.
  5. Delete the IDE system (idea.system.path) directory.
  6. In most cases the issue should be already resolved, but if the IDE still doesn't start with the same error dialog, you can also try to backup and delete the configuration directory (idea.config.path).
  7. Contact support with the full exception stacktrace (you can copy/paste it from the error dialog).

Feedback

We'd appreciate if you report all such issues to the support team or directly to the issue tracker. We are trying to eliminate the root cases and make the IDE recovery process more seamless.

119 out of 596 found this helpful
409 comments

@Danialdanish574  Please remove `~/Library/Application Support/Google/AndroidStudioX.Y/studio.vmoptions` (replace X.Y to real AS version) or split -Xmx2048m and -XX:MaxPermSize=512 in this file into two lines instead of one line.

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@AoEiuV020 Please try the suggestion here: https://stackoverflow.com/a/61913060

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@Leija Chen @LeijaChen Hi i tried to split it but it still shows the same error. 

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@Danialdanish574 Does it help if you remove `~/Library/Application Support/Google/AndroidStudioX.Y/studio.vmoptions` file directly?

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@Leija Chen @LeijaChen THANK YOU SO MUCH it finally worked! i removed the studio.vmoptions file but it didnt work, then i use the command search and find out i have 2 android studio.didnt know which one im using but i removed the file from both application and now its working again.thank you very much

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Getting this error on Amazon Linux 2 on the latest release of Intellij Idea ultimate version 2024.3

Cannot start the runtime

Caused by:
   0: Failed to load 'libjvm.so'
   1: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /home/jp003671/.local/share/JetBrains/Toolbox/apps/intellij-idea-ultimate/jbr/lib/server/libjvm.so)

Please try to reinstall the IDE.
For support, please refer to https://jb.gg/ide/critical-startup-errors


fixed by:https://youtrack.jetbrains.com/issue/JBR-7687/IDEA-2024.3-EAP3-wont-start-on-CentOS-7-jbr-lib-server-libjvm.so-because-lib64-libm.so.6-version-GLIBC2.27-not-found

Edited by John Ferron
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Hi Team, 

Greetings!!!

I am getting issue while setting Intellij. I have install the product IDEA 2024.2.1 version but it is giving error below.    Any work aound to get it resolved? 

-----------------------------

Cannot start the IDE
-----------------------------

Cannot find a runtime
 

Caused by:
Runtime not found
Please try to reinstall the IDE,
For support please refer to httpsifib.gg/ide/critical-startup-errors

-----------------------------

OK

-----------------------------

Thanks & Regards,

Kamleshkumar Gujarathi

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Kamlesh Gujarathi Make sure you installed the app on the supported OS and for the correct CPU architecture. Download the correct version if it's not the case. See also https://intellij-support.jetbrains.com/hc/en-us/articles/206544879 . Run with the launcher in debug mode to get more details about the problem in the console output: https://intellij-support.jetbrains.com/hc/en-us/articles/360011901879-How-to-start-IDE-from-the-command-line .

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JDK version installed 21.0.5.0

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I have installed it on Windows 10 enterprise - This is in company VDI 

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I am using below Pycharm Professional Edition. I am getting an exception while I am updating Github Copilot plugin.

------- Pycharm Professional Edition--------------

PyCharm 2024.1.3 (Professional Edition)
Build #PY-241.17890.14, built on June 4, 2024
Licensed to Capital Group

Runtime version: 17.0.11+1-b1207.24 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 4060M
Cores: 8
Registry:
 ide.windowSystem.autoShowProcessPopup=true
Non-Bundled Plugins:
 aws.toolkit.core (3.59-241)
 com.github.copilot (1.5.2.5345)
 com.leinardi.pycharm.pylint (0.16.4)
 amazon.q (3.59-241)
 aws.toolkit (3.59-241)
 

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 I have installed IntelliJ on my windows systems but its failing to startup below is the error am getting. Despite Installing the JDK and the the path correctly and surprisingly i have Pycharm in the same laptop and its working just fine. i have tried to troubleshoot but to no avail…need help. My laptop Specs are

Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz   1.80 GHz

12.0 GB (11.9 GB usable)

64-bit operating system, x64-based processor

Windows 11 Pro

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Whenever I go to the Python Packages button on the bottom left in PyCharm Community, I get this error messages:

It won't close until I select the Terminal button on the bottom left, then close PyCharm and restart. But if I click on the python packages button again, same error. 

I have reinstalled several times with and without the Toolbox and still get this error.

Any suggestions?

Thanks

Edited by Jnbutler1815
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Can comeone help with this issue, I'm new to Intelij Idea, just installed it and have error like this

 

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I couldn't start the app today. This happened after some plugin updates and a request to restart. I'm using the latest IntelliJ IDEA version (2025).
 

The Reset Settings & Plugins and Report Problem buttons do nothing.

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@Rusmacari Could you please try to reinstall your IDE from scratch? It seems some necessary files are missing for this IDE installation. You can find the download link here: https://www.jetbrains.com/idea/download/other.html

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`Error occurred during initialization of VM<br>agent library failed Agent_OnLoad: instrument<br><br><br>Please try to reinstall the IDE.<br>For support, please refer to https://jb.gg/ide/critical-startup-errors`

I'm getting this error with webstorm. Other products are working fine.

I'm using Toolbox to install the IDEs.

I followed [this](https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs) and the linux section to remove all webstorm related configurations, systems, logs, and plugins but to no avail. Any ideas?

 

Edited by Jokesome Roxburgh
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